Cancel
Top Search Terms

What Software Should I be Using?

    Is my "+" printer compatible with MakerBot Print?

    If you're using the MakerBot Replicator+ and MakerBot Mini+, you should be using MakerBot Print. Older software types will not function with your MakerBot Replicator+ or MakerBot Replicator Mini+.

    Click here for information on the system requirements.

    Can I use MakerBot Print with an older printer type?

    Yes, MakerBot Print is compatible with the following printers: 

    • MakerBot Replicator (Fifth Generation)
    • MakerBot Replicator Mini
    • MakerBot Replicator Z18
    • MakerBot Replicator 2 (Export only)
    • MakerBot Replicator 2X (Export only, Dual Extrusion Printing NOT supported)

    What can I use MakerBot Desktop for? 

    MakerBot Desktop can be used to take advantage of the Dual Extrusion features on the Replicator 2X and to connect to the Replicator 2 and Replicator 2X via USB

    If your 5th generation printer has firmware 1.9.2 or older, you will need to download MakerBot Desktop to update the firmware to 2.0 or higher.

    To learn how to install MakerBot Desktop, click here.

    There are a few devices and operating systems that are not supported by current versions of MakerBot Desktop or MakerBot Print:

    • Windows 8 and MAX OS X 10.8- are not supported by MakerBot Print. Windows XP and Mac OSX 10.6 are no longer supported by MakerBot Desktop. If you are using one of these operating systems, older versions of MakerWare are available for you to use. You can use MakerWare 2.2 for Windows XP, and MakerWare 2.4.1for Mac OSX 10.6. To download and install either of these versions, click here

    • If you have a MakerBot Digitizer, use MakerWare for Digitizer. To install MakerWare for Digitizer, go to makerbot.com/desktop and download the latest version of MakerWare for Digitizer. During the installation process, make sure the “MakerWare for Digitizer” checkbox is selected.

    • The MakerBot Thing-O-Matic is no longer supported by the most recent version of MakerBot Desktop. You can still use your Thing-O-Matic with MakerBot Desktop 3.7 or earlier. Your Thing-O-Matic must have a Gen 4 LCD Interface and run Sailfish 4.1 or higher to be compatible with these earlier versions of MakerBot Desktop 3.7. To download MakerBot Desktop 3.7, click here.

    • If you have a MakerBot CupCake, use ReplicatorG.



    Need Help?

    Call our Support team
    Monday — Friday | 9am — 6pm ET

    +1 925 529 8563

    Activate Your Service Plan

    Register your device to ensure you get the right level of service and support.

    What can we help you with today?
    I want to chat with Sales.
    I have a question about an existing order.
    I have a technical question about my device.
    Continue
    Existing Orders
    For faster service, enter your order number
    (found in your confirmation e-mail)
    Skip
    Submit