Cancel
Top Search Terms

How to Prepare a Model for Printing

    Adding Models

    You can add a model from the Explore or Library sections of MakerBot Desktop by clicking the Prepare button next to any model or Thing.

    To add a model from outside MakerBot Desktop, click Add File. Navigate to the location of any STL, OBJ, or Thing file and select the file to add a model to the build plate.

    You can add as many models to the plate as will fit. Use the keyboard shortcut Ctrl/Command + L to automatically arrange multiple models on the plate.

    Duplicate models already on the plate using the Copy and Paste options in the Edit menu or the keyboard shortcuts Ctrl/Command+C and Ctrl/Command+V. 

    Manipulating Models

    When you open a model in the Prepare section of MakerBot Desktop it will appear on a virtual representation of your MakerBot 3D printer's build plate. If the build plate on your screen isn't the right size, go to Devices > Select Type of Device and select the type of MakerBot 3D printer you're using.

    The video below provides general guidelines on how to manipulate files on your build plate in MakerBot Desktop.

    View Options

    Click the Homebutton to reset MakerBot Desktop to the default view of the build plate.

    Click the Plus and Minus buttons to zoom in and out. You can also zoom using a track pad or the scroll wheel on your mouse.

    Click the View button or press the V key to enter View mode.

    • In view mode, click and drag with your mouse to rotate the build plate.
    • In view mode, hold the Shift key and click and drag with your mouse to pan.
    • Click the View button again to open the Change View submenu and access preset views.

    Model Options

    Click the Move button or press the M key to enter Move mode.

    • In Move mode, click and drag with your mouse to move your model around on the build plate.
    • In Move mode, hold down the Shift key and click and drag with your mouse to move your model up and down along the Z-axis.
    • Click the Move button again to open the Change Position submenu and center your object or move it by a specific distance along the X-, Y-, or Z-axis. 

    Click the Turn button or press the T key to enter Turn mode.

    • In Turn mode, click and drag with your mouse to rotate your model around the z-axis.
    • Click the turn button again to open the Change Rotationsubmenu and lay your object flat or rotate it by a specific number of degrees around the X-, Y-, or Z-axis. 

    Click the Scale button or press the S key to enter Scale mode.

    • In Scale mode, click and drag with your mouse to shrink or enlarge your model.
    • Click the Scale button again to open the Change Dimensions submenu and scale your object by a specific amount along the X-, Y-, or Z-axis.

    Extruder Information Options

    If your MakerBot 3D printer has dual extruders, click the Information button or press the O key to enter Object Information mode.

    • In Object Information mode, use the drop-down menu to determine whether an object on the build plate should be printed by the right extruder or the left extruder. If you have multiple objects on the build plate, you can set which one will be printed by which extruder. Use the Select All button to set the extruder for multiple objects at once.

    Saving Files

    Click Save To Library to save a model or layout in your MakerBot Cloud Library as a Thing file. Click Save To Library > Save Local File to save locally as a Thing, OBJ or STL file. Click Export Print File > Export Now to save locally as a .makerbot file (5th Generation MakerBot 3D printers) or X3G, S3G, or GCode file (older MakerBot 3D printers). For more information about saving files, click here.

    Print Settings

    If you want to change any settings before printing, click Settings. This is where you can specify options that will affect the quality of your printed object, like print resolution and object strength. To print with the settings you used for your last print, or with standard settings if you’re using MakerBot Desktop for the first time, skip this step and go straight to printing.

    Use the Quick settings tab to change basic quality, temperature, and material settings, and to turn rafts and support on and off. Use the Custom settings tab to make detailed changes to the way your model is sliced, or to create a custom profile. For more details on print settings, click here

    Printing an Object

    Make sure your MakerBot 3D Printer is connected to MakerBot Desktop. To print the model currently on the virtual build plate, just press Print. MakerBot Desktop will slice your model using the current settings. For more detailed instructions, see below.

    Fifth Generation MakerBot 3D Printers

    • Printing Directly: If your MakerBot 3D printer is connected via Wi-Fi, USB, or Ethernet, click Print to start the slicing process. Once MakerBot Desktop tells you that the file has been transferred, confirm the print on your MakerBot 3D printer or in MakerBot Desktop. Note: The Replicator+ and Replicator Mini+ will have difficulty communicating with the MakerBot Desktop software, please use MakerBot Print instead.
    • Exporting a Print File: To print via USB drive or to save a print file for later, first make sure the correct MakerBot 3D printer is selected in the Devices menu. Then click Export Print File. Your model will be sliced and exported. Print files exported for Fifth Generation MakerBot 3D printers should have a .makerbot file extension. To print a model that has been sliced as a .makerbot file via MakerBot Desktop, go to File > Print from File, select the .makerbot file and click Open. MakerBot Desktop will send the file to your 3D printer.

    • Note: The MakerBot Replicator Mini must be connected via Wi-Fi or USB to print.

    Older MakerBot 3D Printers

    • Printing Via a Connection: If your MakerBot 3D printer is connected via USB, click Print to start the slicing process. MakerBot Desktop will let you know when the file is ready to print.
    • Exporting a Print File: To print via SD card, first make sure the correct MakerBot 3D printer is selected in the Devices menu. Then click Export Print File. Your model will be sliced and exported. Print files exported for most earlier MakerBot 3D printers should have a .x3g file extension.

    3D Printer Status

    The bar at the bottom of the MakerBot Desktop screen shows the status of your connection to your MakerBot 3D printer. If you do not have a 3D printer connected to your computer, this bar will show which MakerBot 3D printer is currently selected in the Devices menu.

    Click the menu icon at the right side of the status bar in order to open a print monitor panel. The print monitor panel displays:

    • The progress of any current print
    • More detailed information about your 3D printer's status
    • A camera view of the build area for any Fifth Generation MakerBot 3D printer connected via a network

    Note: MakerBot Desktop is no longer in development. To upgrade to our newer software, please install MakerBot Print.


    Need Help?

    Call our Support team
    Monday — Friday | 9am — 6pm ET

    +1 925 529 8563

    Activate Your Service Plan

    Register your device to ensure you get the right level of service and support.

    What can we help you with today?
    I want to chat with Sales.
    I have a question about an existing order.
    I have a technical question about my device.
    Continue
    Existing Orders
    For faster service, enter your order number
    (found in your confirmation e-mail)
    Skip
    Submit